ورڈپریس میں خودکار کی ناکامی؟ ایف ٹی پی میں ناکامی؟

WordPressحال ہی میں ، ہمارے پاس ایک مؤکل موجود تھا جس نے ورڈپریس کے ساتھ استعمال کے ل their اپنے سرورز کو تشکیل دیا۔ جب حالیہ 3.04 سیکورٹی اپ ڈیٹ ہوا ، ہمارے تمام مؤکلوں پر یہ ورژن انسٹال کرنے کے لئے فوری طور پر کچھ احساس تھا۔ تاہم ، اس مخصوص موکل کو ہمیشہ یہ ضرورت ہوتی ہے کہ ہم ورڈپریس کو دستی طور پر اپ گریڈ کریں… ایسا عمل جو دل کے بے ہودہ ہونے کے لئے نہیں!

ہمیں عام نہیں ملے گا “فائلیں نہیں لکھ سکتے ہیں”اس بلاگ پر غلطی۔ اس کے بجائے ہمیں ایف ٹی پی لاگ ان کے ساتھ اسکرین فراہم کی گئی تھی۔ مسئلہ یہ تھا کہ ہم ایف ٹی پی کی اسناد کو بھریں گے اور یہ ہوگا پھر بھی ناکام… اس بار اچھی اسناد کی بنیاد پر!

میں نے انڈیانا کے لائف لائن ڈیٹا سینٹرز میں اپنے دوستوں سے رابطہ کیا سب سے بڑا ڈیٹا سینٹر، چونکہ ان کے پاس کچھ اپاچی گیکس ہیں اور انھوں نے اپنے سرور تشکیل دیئے ہیں۔ انہوں نے مجھے ایک آسان حل فراہم کیا WP config.php FTP اسناد کو ہارڈ کوڈ دینے کے لئے فائل:

وضاحت ('FTP_HOST'، 'لوکل ہوسٹ')؛ ('FTP_USER'، 'صارف نام') کی وضاحت؛ ('FTP_PASS'، 'پاس ورڈ') کی وضاحت؛

کسی وجہ سے ، ایک جیسی اسناد جو فارم میں کام نہیں کرتی تھیں ، ترتیب فائل میں ڈالتے وقت بالکل کام کرتی تھیں! نیز ، یہ ورڈپریس کو ایسے ہی کام کرتا ہے جیسے یہ ایف ٹی پی کی ضرورت کے بغیر ہوتا ہے…. صرف اپ ڈیٹ پر کلک کریں اور جاؤ!

۰ تبصرے

  1. 1

    میں نے اپنے سرور کو دوبارہ تعمیر کرنے اور ایک نیا ورڈپریس انسٹالیشن گھماؤ کرنے کے بعد ورڈپریس آٹو اپ ڈیٹ کی غلطیوں کا سامنا کیا۔ میرا مسئلہ فائر فاکس سے پیدا ہوا ، ورڈپریس سے نہیں - دوسروں کو بھی اسی مسئلے کا سامنا کرنا پڑ سکتا ہے اگر ان کا ایف ٹی پی صارف نام اور ورڈپریس صارف نام میرے جیسے ہی ہے (حالانکہ مختلف سرمایہ اور پاس ورڈ کے ساتھ)

    مسئلہ یہ ہے کہ فائر فاکس ، اگر آپ کے پاس "پاس ورڈ یاد رکھنا" قابل ہیں تو ، صارف / فارم کو خود بخود درست کردے گا جو اس کے خیال میں ہے جو اس کے پاس ورڈ منیجر میں رکھے ہوئے چیزوں پر مبنی ہونا چاہئے۔ میرے معاملے میں ، میرے ورڈپریس کی اسناد محفوظ ہوگئیں ، لیکن میرے ایف ٹی پی کی اسناد نہیں تھیں ، کیوں کہ وہ سائٹ میں ایس ایس ایچ کے لئے استعمال ہوسکتی ہیں۔ جب اس ورڈپریس کو آٹو اپ ڈیٹ استعمال کرنے کی کوشش کی جا or یا اس سلوک کو درست کرنے کے لئے ورڈپریس پر کوڈ کا ایک ٹکڑا لگائیں تو اس صورتحال میں لوگ اپنی ترجیحات / اختیارات میں عارضی طور پر "پاس ورڈز کو یاد رکھیں" کو غیر فعال کرسکتے ہیں۔

  2. 2

    ڈوگ ،

    مجھے اپاچی کے گھر بنانے میں بھی یہی مسئلہ تھا۔ پتہ چلتا ہے کہ یہ کچھ فائلوں اور ڈائریکٹریوں پر نامناسب اجازتوں اور ملکیت کا نتیجہ ہے۔

    http://robspencer.net/auto-update-wordpress-without-ftp/

    مذکورہ لنک نے ایف ٹی پی کی اسناد کا استعمال کیے بغیر مسئلے کو درست کرنے کے طریقے کی بصیرت فراہم کی۔ یقینا میں تجویز نہیں کرتا ہوں کہ آپ اپنی پوری صارف ڈائرکٹری کو 775 پر گونج دیں (اور میں نے نہیں کیا) لیکن اس سے مجھے صحیح سمت میں لے جایا جاتا ہے۔

    آدم

  3. 3

    دوسروں کے لئے جو ممکنہ حل تلاش کررہے ہیں: ایک اور بلاگر نے بظاہر اپنے میزبان کو اپنی .httaccess فائل میں مندرجہ ذیل شامل کرکے پی ایچ پی 5 استعمال کرنے پر مجبور کرکے اپنے آٹو اپ ڈیٹ کے مسائل حل کردیئے۔

    ایڈ ٹائپ ایکس میپ - پی ایچ پی 5. پی ایچ پی

  4. 4

    علم کو بانٹنے کے لئے آپ کا شکریہ ، میں نے آٹو پیڈٹس میں پریشانی کا سامنا کیا ہے لیکن اس کا واحد حل یہ ہے کہ پلگ ان کو غیر فعال کریں پھر ورڈپریس کو خودکار بنائیں اور آخر میں تمام پلگ انز کو رد عمل دیں۔

    یہ نوک ایک پیچیدہ مسئلہ کے لئے ہے لیکن اسے حل کرنے کا طریقہ جاننا اچھا ہے۔

    میکسیکو سے مبارکباد!

آپ کا کیا خیال ہے؟

سپیم کو کم کرنے کے لئے یہ سائٹ اکزمیت کا استعمال کرتا ہے. جانیں کہ آپ کا تبصرہ کس طرح عملدرآمد ہے.